Inicio > Intermedio, Linux, Redes, Software > Openvpn falló porque no había secretos vpn válidos.SOLUCIÓN

Openvpn falló porque no había secretos vpn válidos.SOLUCIÓN

Si habéis llegado hasta aquí ha sido porque habéis montado un cliente con el PLUGIN OpenVPN para Network-Manager y no hay forma humana de que no os salga esto, ¿verdad?, aunque re-configuréis el cliente.conf os sigue saliendo continuamente, ni siquiera da tiempo a cargar el .conf entero y ya os sale este mensajito.

No pasa nada, porque para eso estoy aquí, para solucionar este pequeño inconveniente que os trae de cabeza.

Sin más preámbulos:

Consola en modo ROOT:

sudo gedit /etc/dbus-1/system.d/nm-openvpn-service.conf

Ahora ese texto que sale, lo sustituís por este (entero):

<!DOCTYPE busconfig PUBLIC
“-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN”
http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd”&gt;
<busconfig>
<policy user=”root”>
<allow own=”org.freedesktop.NetworkManager.openvpn”/>
<allow send_destination=”org.freedesktop.NetworkManager.openvpn”/>
</policy>
<policy user=”at_console”>
<allow own=”org.freedesktop.NetworkManager.vpnc”/>
<allow send_destination=”org.freedesktop.NetworkManager.vpnc”/>
</policy>
<policy context=”default”>
<deny own=”org.freedesktop.NetworkManager.openvpn”/>
<deny send_destination=”org.freedesktop.NetworkManager.openvpn”/>
</policy>
</busconfig>

Guardáis datos, salís del gedit y reiniciáis el ordenador (también vale reiniciar sólo el network-manager pero te complicas menos reiniciando), ya nos os dará el famoso error de: Openvpn falló porque no había secretos vpn válidos.

Nota:

Realmente lo único que haces es intercalar esta línea de código:

<policy user=”at_console”>
<allow own=”org.freedesktop.NetworkManager.vpnc”/>
<allow send_destination=”org.freedesktop.NetworkManager.vpnc”/>
</policy>

Entre las otras dos, pero os puse el código entero para que no os compliquéis la vida.

Espero que os haya servido😉

Categorías:Intermedio, Linux, Redes, Software
  1. miguelo
    29 junio 2011 a las 16:31

    yo reemplacé el grupo de políticas que dice

    por

    y funcionó

  2. Manolo
    5 junio 2012 a las 11:19

    A mí también me funcionó. Gracias!

  3. 27 julio 2012 a las 15:47

    Hola .. que usuario y que clave es la que se digita para acceder a la vpn desde winxp?

  4. Anónimo
    12 diciembre 2015 a las 23:32

    no me funciono amigo y hice todo como lo explicaste

  1. 23 junio 2010 a las 23:14
  2. 16 febrero 2011 a las 5:20
  3. 3 diciembre 2013 a las 2:57
  4. 22 octubre 2015 a las 18:12
  5. 27 octubre 2015 a las 5:59

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: